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Introduction

What is TracePro?
TracePro is a comprehensive, versatile software tool for modeling the propagation of light in
imaging and non-imaging opto-mechanical systems. Models are created by importing from a lens
design program or a CAD program or by directly creating the solid geometry in TracePro. Sources
propagate through the model with portions of the flux of each traced ray allocated for absorption,
specular reflection and transmission, fluorescence and scattering. From the model, analyze:

• Light distributions in illumination and imaging systems
• Stray light, scattered light and aperture diffraction
• Throughput, loss, or system transmittance
• Flux or power absorbed by surfaces and bulk media
• Flux or power scattered by surfaces and bulk media
• Luminance and radiance maps
• Candela distributions
• Polarization effects
• Fluorescence effects
• Birefringence effects

TracePro has a simple, intuitive interface and short learning curve. It is compatible with
commercially available CAD programs such as SolidWorks®, AutoCAD®, Pro/E® and CATIA®. It
can share solid modeling data with all other software based on ACIS, and exchange data with
most other CAD programs and analysis programs via IGES and STEP files. It can also import data
from commercially available lens design programs including (OSLO, ACCOS V, Code V, Sigma,
and ZEMAX). TracePro runs on Windows based PCs.

What Is the Trial Version?
This Trial Version of TracePro is a working copy of the software with certain key features disabled.
Core functionary including geometry creation, ray tracing and analysis is enabled. Material and
surface property data may be viewed but not edited. Example models are provided that illustrate a
sample of the addressable applications.

The Trial Version disables the following functionality:

• Saving models to disk
• Printing
• Applying optical properties to objects and surfaces
• Importing or exporting CAD files
• Macro processing

System Requirements
TracePro requires a PC running Windows XP or Windows 2000. A minimum of 512MB of RAM is
required. 1024 MB is the recommended minimum. Additional physical memory the more rays you
can trace without TracePro using virtual memory. Using virtual memory significantly decreases the
speed of a TracePro raytrace. Many TracePro users use 512MB or more of physical RAM.
TracePro requires at least 128 MB of disk space for installation. A minimum allocation of 512MB
of Virtual Memory is required. This is controlled in Windows 2000/XP by selecting
Start→Settings→Control Panel, double-clicking on the System icon, and specifying in the
Performance tab.
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Installing the TracePro Trial Version

The installation procedure for TracePro is as follows:

• Insert the TracePro CD-ROM into the drive.
• Select Install TracePro from the TracePro Setup Utility which automatically launches when the 

CD is inserted [OR… Run setup.exe using Windows Explorer or by selecting 
Start→Settings→Control Panel and running the Add/Remove Programs]

The installation program will create a TracePro item on the Programs menu. A detailed description
of all installation options is provided in the TracePro Installation Guide.

Running TracePro
To start TracePro, select Start→Programs→TracePro.

FIRST TIME NOTE:

TracePro needs to know the location of the TRACEPRO.MDB file. This file contains the material
and surface property data. If TracePro cannot locate the file, it will prompt you to specify the
location of the file, then present you with an Open File dialog box. Using this dialog box, locate the
TRACEPRO.MDB file (it is probably in the TracePro directory) and press OK. The new path will be
stored in the TracePro.INI file so that the next time you start TracePro you can skip this step.

Next, TracePro will display the following dialog box offering to let you run TracePro in
demonstration mode. Other options are available for licensed versions or more extensive Trials
and evaluations.

FIGURE 1 - TracePro License Information
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Select TracePro Demonstration Version with functional restrictions and click OK. 

The TracePro Demonstration dialog box will appear as shown below. Select Run Demo and
TracePro will start.

FIGURE 2 - TracePro Demonstration Dialog

Get Started
You can start by opening one of the prepared examples as described below. Many of the viewing
functions (Zoom Window, Orbit View, Rotate View) are performed interactively using the mouse.
For example, after opening any of the files, you can rotate the view using the Rotate View option.
Press the Orbit Rotate View button on the toolbar (or select View|Rotate|Orbit from the menu),
then move the mouse cursor inside the geometry window. Press and hold the mouse button down,
move the mouse around, and watch the view change in real time as you move the mouse.

The Zoom Window command operates the same way as in a CAD program. Press the Zoom
Window button, press and hold the mouse button down at one corner of the region you would like
to zoom to, drag the mouse to the opposite corner of the region, and release the button. You can
also zoom in or out using the Zoom In and Zoom Out buttons.

TracePro features multiple views and multiple documents. Using the Window|New menu item (or
the New Window toolbar button), you can open as many views as you like of the current model.
You can also have as many models open at one time as you wish, with as many views of each as
you wish as well. There are practical limits to this, of course, imposed by your computer’s memory
and screen area. You can choose from silhouette view (the default), rendered view, hidden line, or
wireframe view using the View menu.

You can access context-sensitive help anytime by pressing F1 or by using the Help button on the
toolbar in TracePro.

Example Files
When TracePro is installed several example models are transferred onto your computer. The files
are placed under the Examples folder in the TracePro folder in Demos. The TracePro folder is
installed on your computer in “C:\Program Files\Lambda Research Corporation\TracePro” by
default. If you changed the location or are starting Windows on an alternative disk drive, the full
path may be different. 
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Example - Stray Light in a Photolithography Lens

This model domesticates a simple stray light analysis - via., analyzing ghost images in a refractive
lens system. The model contains a multi-element lens system including lens barrels, retaining
rings, and other mount design details. The lenses are made of Schott glasses. With the exception
of the third lens element that is uncoated, all lenses surfaces are modeled with anti-reflection
coatings and surface scattering. The non-optical surfaces are coated with diffuse black paint.

From the File menu select Open. Navigate to the Demos folder and open the Lens Demo folder.
See “Example Files” on page 6. Pick lensdemo.oml and press Open. After the file is opened, a
side view of the lens will be displayed in the Model Window, as shown below.

FIGURE 3 - Photolithography Lens Model

Now select View|Profiles|Iso 1 to see an isometric view of the lens system. You can also see
a rendered view of the lens by selecting View|Render. It will take a few seconds for TracePro to
calculate the rendered view. Return to the y-z silhouette view by first selecting
View|Silhouettes, then selecting View|Profiles|YZ. Now we are ready to ray-trace the model.

Select Define|Grid Source from the menu to open the Grid Setup dialog box as shown below.
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The settings specify a line of rays lying in the y-z (vertical) plane, and directed horizontally along
the +z axis. 

FIGURE 4 - Grid Raytrace Dialog

Ray Tracing
Ray Tracing is the means by which TracePro simulates the distribution of flux throughout a model.
How rays interact with the model is determined by the model itself (the geometry of created objects
and their applied properties), and how you control the rays being launched into the model. There
are three basic methods of defining rays: Grid Sources, File Sources and Surface Sources. 

The next step in this example is ray tracing. From the menu, select Analysis|Trace Rays. Select
Trace Source using discrete wavelengths. Select All for Grid; select None for Surface; select None
for File. Press the Apply button. Press the Trace Rays button. 
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FIGURE 5 - Trace Rays Dialog

First, TracePro will perform an Audit of the model to ensure that all surface and material properties
are in the database and to preprocess the geometry in the model for faster ray tracing. After the
ray-trace is finished, the rays will be displayed in the Model window as shown below.

FIGURE 6 - Ray Trace of Photolithography Lens Model 

This ray-trace shows image-forming rays and some ghost rays caused by reflections from the
uncoated element. The image-forming rays converge to a point at the image plane. The ghost rays
are the ones reflected from lens element #3. They are terminated when their flux falls below the
flux threshold, or go back out the front of the lens system.

Imaging Rays
Ghost Rays
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Flux Threshold
The flux threshold is used to control the ray-trace. As rays are traced in the model, they are split
into two or more components. For example, at the surfaces of lens element #3 in this model, the
incident ray is split into two new rays, one transmitted and one reflected. The flux or power carried
by these split rays is proportional to the transmittance and reflectance of the surface. This splitting
process occurs at each ray-surface intercept, with the flux of each ray segment decreasing at each
ray-surface intercept. When the flux of the ray drops below the Flux Threshold, the ray is
terminated. The flux threshold is controlled using the Analysis|Raytrace Options dialog. Select
the Thresholds tab and change the Flux Threshold from 0.05 to 0.0002. Rerun the ray-trace.
This will produce many more rays (and the ray-trace will take longer to finish). Some ghost rays
will reach the image plane, causing stray light.

FIGURE 7 - Threshold Tab in Raytrace Options Dialog

This example illustrates how TracePro can be used for stray light analysis. With its modeling of
scattering and its importance sampling feature, TracePro can predict stray light in telescopes and
other optical systems that have high attenuation of stray light. By examining ray paths using the
Ray Sort feature, design alternatives to improve stray light performance are identified.
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Example - Metal Halide Lamp with Elliptical Reflector

This example contains a simplified model of a metal halide lamp with an elliptical reflector,
electrodes with a plasma arc and quartz enclosure, and an output plane. The arc is simulated as a
cylinder that radiates in a Lambertian pattern from its cylindrical surface.

From the File menu select Open. Navigate to the Demos folder and open the Elliptical Reflector
folder. See “Example Files” on page 6. Select eliprefl.oml and press Open. After the file is opened,
a side view of the lens will be displayed in the Model Window, as shown below.

FIGURE 8 - Elliptical Reflector Model 

The Model window will be displayed after you open the file. To see the display shown above, you
must open the System Tree. Just inside the left border of the model window is a vertical splitter
bar. Place your mouse cursor on this splitter bar and you will see a special splitter cursor. Press
and hold down the mouse button and drag the splitter bar to the right to expose the System Tree.
Items with a + in the System Tree can be expanded by a single mouse click on the +. Once
expanded, the + changes to a -. You can collapse an expanded item by clicking on the -.

TracePro describes models as collections of Objects, each of which are bounded by one or more
Surfaces. For example, a sphere object has one bounding surface, and a cube object has six
bounding surfaces. Objects have Material Properties specified by name, like Glass or Aluminum,
and Surfaces have Surface Properties, like Mirror, Lens, or Black Paint. Objects have main
branches on the system tree, and surfaces have sub-branches.

Defining Rays with Source Types
Sources are defined as Grid, Surface and File. Grid Source are defined as virtual windows to a
distant source with rays emanating from the window. Surface Sources are applied as a property to
an object’s surface. File Sources are comprised of external ray data read by TracePro during the
ray trace. Each of the source types can be defined from the Define menu or by Right-Clicking in
the Source Pane of the System tree.

The Source Pane in the System Tree is a central repository for all sources contained in the model.
Each source is displayed as a node in a Source Tree. Expanding a node displays the various
sources of each type and further displays the relevant data for each source. Each source node is
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preceded by a Green Check or Red X. Clicking on this flag will add or remove the source from the
list of sources to trace.

Any surface in a TracePro model can be made a source of light by making it a Surface Source.
The cylindrical source in the eliprefl.oml example has a Surface Source property assigned to it.
The total flux that will be emitted by the surface is 10 lumens and the emission will be simulated
using 1000 rays. The characteristics are shown above in the Model Pane of the System Tree and
below in the Source Pane of the System Tree where a Green Check is set indicating it us enabled
for raytracing. 

FIGURE 9 - Source Pane in System Tree

The next step in this example is ray tracing. From the menu, select Analysis|Trace Rays. Select
Trace Source using discrete wavelengths. In Sources to Trace, select None for Grid; select
Checked Only for Source; select None for File. Press the Trace Rays button. You can also start
this type of ray-trace by pressing the Source Trace button on the Analysis toolbar after selecting
defined Surface source in the Source Pane of the System Tree

The progress of the ray-trace is displayed in the progress dialog and the ray-trace can be
interrupted at any time by pressing Cancel. 

After the raytrace is finished, rays will be displayed in the Model window as shown in the figure
below. One focus of the ellipse is at the center of the cylindrical source, and the Front surface of
the Observation Disk object is at the other focus. You can see the irradiance map for this surface,
but first you must select it for viewing. To do this, expand the Observation Disk in the System Tree
so that it looks like the figure below, and click on Front to select it.

Below is an Irradiance Map of the output. Select Analysis|Irradiance Maps (or press the
Irradiance Maps button) to see this irradiance map.
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FIGURE 10 - Ray Trace and Illuminance Map of Elliptical Reflector Model

You can also create a candela plot to see the angular distribution of light coming out of the lamp.
Select Analysis|Candela Plots|Polar Iso-Candela to get the plot shown below. This is a
polar plot of candela versus angle, and shows the intensity per unit solid angle, or lumens/
steradian.

Select the Front Surface
of the Observation Disk

Outline of Selected
Surface
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FIGURE 11 - Polar Iso-Candela Plot of Elliptical Reflector

To create a candela plot, select Analysis|Candela Options to open the dialog box shown below.
Set the Ray Selection to “Use incident rays from selected surface” and click Apply button.

FIGURE 12 - Candela Options Dialog

In the above Candela plot, if you move the mouse cursor over on the candela plot, the status bar at
the bottom of the TracePro window shows the angular coordinates and the candela value at the
location of the mouse cursor. You can also display slices through this plot or a smaller square
region within this polar plot. 
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Example - Integrating Sphere

This model simulates an integrating sphere to illustrate tracing of scattered rays and importance
sampling. An integrating sphere is a hollow sphere with a highly reflecting, diffuse coating on the
inside. Often an integrating sphere has an entrance port to let light in, and an exit port to let the
(integrated) light escape. In this model, however, the sphere has only an exit port, and rays are
emitted from a virtual source inside the sphere. This integrating sphere has a diffuse coating with
99% reflectance on the inside.

From the File menu select Open. Navigate to the Demos folder and open the Integrating Sphere
folder. See “Example Files” on page 6. Pick intspher.oml and press Open. 

FIGURE 13 - Integrating Sphere Model
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This model has the flux threshold set to 5x10-5. This allows rays to scatter many times within the
sphere before being terminated. To see how to set this threshold, select Analysis|Raytrace
Options to open the dialog box shown below right, and select the Thresholds tab.

FIGURE 14 - Raytrace Options Dialog 

Now open Source Pane in System Tree and notice that the number of rays for Grid Source 1 is set
to one. Press the Source Trace button on the Analysis toolbar.

FIGURE 15 - Ray Trace of Integrating Sphere Model 

The previous figure shows a close-up view of the integrating sphere output port for a single
starting ray.
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Select View|Zoom|Window (or press the Zoom Window button) then zoom in on the exit port at the
bottom of the sphere to get the view shown on the previous page. Zooming to a window is
described in the “Get Started”.

As you can see, one starting ray produces many ray components as the ray scatters many times
inside the sphere. Each time a ray segment strikes the inside surface of the sphere, one
importance sampling ray is directed toward the exit port of the sphere. This process of importance
sampling greatly increases the sampling (i.e. number of ray components) at the exit port and thus
improves the efficiency of the ray-trace.

Importance Sampling
Importance sampling is a technique for improving the sampling in the Monte Carlo method. It is
essential for studies like stray light analyses, wherein only a tiny fraction of the incident light
reaches the image surface. In a well-baffled telescope, 10-10, 10-15, or even less of the flux from
the source may reach the image surface. In a “brute force” Monte Carlo raytrace in which rays find
their way to the image surface by random scattering only (without importance sampling), an
enormous number of rays must be traced to get only a few rays through the system. For example,
if 10-10 of the incident flux reaches the image surface, you must start 1010 rays to produce one ray
at the image surface, on average. 

In TracePro, importance sampling is a technique in which scattered rays are sent in specified
directions in the optical system, such as toward the exit port of this integrating sphere. The
probability of these rays reaching the exit port is thereby increased to one by this process, so the
flux carried by them is reduced by the probability of them randomly reaching the exit surface. This
calculation is easily done by TracePro during the ray-trace and it assures that energy is
conserved, i.e., that no “double dipping” takes place.

Creating Geometry
You can create the integrating sphere model geometry yourself, although the Trial Version does
not allow you to apply the surface properties needed to do the ray-trace shown above. To create
the hollow sphere needed for the integrating sphere, you define two concentric solid spheres and
subtract the smaller one from the larger to create a spherical shell. To accomplish this, do the
following steps:

1. Select File|New or press the New button to open a new model window.

2. Select Insert|Primitive Solid and select the Sphere tab.

3. Enter 50 for the Radius and press the Insert button. A sphere will be drawn in the window.

4. Change the Radius to 51 and press the Insert button. A second sphere will be drawn.

5. Select Edit|Select|Object (or press the Select Object button on the toolbar) to enable
Object Selection. Click on the Outer Sphere and, press and hold down the Ctrl key, then click
on the Inner Sphere. Zooming in on the edge of the spheres makes it easier to pick the right
one. You can also select items from the System Tree. 

6. Select Edit|Boolean|Subtract (or press the Subtract button on the toolbar).    Once you
complete this, the inner sphere has been subtracted from the outer sphere to produce a
spherical shell.  (If you make a mistake, press the Undo button and try again.)

7. Select the Cylinder/Cone tab on the Insert|Primitive Solids dialog box to prepare to
make a cylinder.  The cylinder will be used to make a hole in the bottom of the spherical shell. 

8. For the cylinder set the Base Major R = 2, Top Length = 20, .

9. Set the Base Position Y = -49, Base Rotation X = 90, and press the Insert button.  A cylinder
will be drawn at the bottom of the spherical shell.  If you had previously zoomed in as
suggested in 5. above, do Zoom All to see the cylinder.
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10. Select the spherical shell and then the cylinder as shown in step 5. Select
Edit|Boolean|Subtract (or press the Subtract button on the toolbar). You have used the
cylinder as a drill bit to drill a hole in the shell.

11. In the Cylinder/Cone tab of the Insert|Primitive Solids dialog box, set the cylinder Top
Length = 1, and Base Major R to 2.5.  Set the Base Position Y = -51 and the Base Rotation X
= 90. Press the Insert button.

The geometry you have created in these 11 steps is identical to the integrating sphere model.
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Example - Luminaire

This model simulates a fluorescent light fixture with louvers. The lamp is represented as a surface
source and the typical output is these applications is a Polar Candela distribution.

From the File menu select Open. Navigate to the Demos folder and open the Luminaire folder.
See “Example Files” on page 6. Pick louver.oml and press Open. The model will look like the
following.

FIGURE 16 - Luminaire with Louvers Model

From the menu select Analysis|Source Raytrace and press the Trace Rays button. You can
also start this type of ray-trace by pressing the Source Trace button on the Analysis toolbar. This
model is set to trace 10,000 rays. Once the raytrace is complete select Analysis|Candela
Plots|Polar Candela Distribution to get the plot shown below. 
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FIGURE 17 - Polar Candela Distribution Plot 
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Example - Eye Model

This model simulates light entering the eye. TracePro uses property information to describe how
light interacts with surfaces and objects (or volumes). The model with traced rays is shown below,
along with a TracePro Flux Report.

From the File menu select Open. Navigate to the Demos folder and open the Eye Model folder.
See “Example Files” on page 6. Pick Eye_Model_CGBF.oml and press Open. Open the Source
Pane in the System Tree and notice that Grid Source 1 is green checked for inclusion in the ray
trace. Press the Source Trace button on the Analysis toolbar to trace the currently defined grid.
The model with rays is shown below.

FIGURE 18 - Eye Model

A Flux Report provides a table of flux distributions throughout the mode. Each surface and object
is shown with the number of incident rays, incident and absorbed flux, and other data. The report is
shown below. The Flux Report is displayed using the Reports|Flux menu.
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FIGURE 19 - Flux Report Table
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Example - Importing Models

This example illustrates how to import model data from CAD and Lens Design programs. Applying
property data is not enabled in the Trial Version. The first example will open a Lens file which will
include the optical properties. The second will open a similar ACIS SAT file without property data.

From the File menu select Open. Navigate to the Demos folder and open the OSLO folder. See
“Example Files” on page 6. Change the Files of type: selection to read OSLO Files
(*.len;*.osl). Pick DEMOTRIP.LEN and press Open. 

Open the Source Pane in the System Tree, right mouse click on Grid Source 1and select Define
Source. Change the Outer radius to 5 and the Rings to 3.  Check Grid Source 1 for inclusion in the
ray trace. Press the Source Trace button on the Analysis toolbar to trace the currently defined grid.
The model with rays is shown below.

FIGURE 20 - OSLO Triplet Lens File opened in TracePro

From the File menu select Open. Navigate to the Demos folder and open the ACIS folder. See
“Example Files” on page 6. Change the Files of type: selection to read ACIS Files (*.sat. Pick
TESSAR.SAT and press Open. The model is in a standard CAD orientation so select the
View|Profiles|XY menu or press the XY View button to rotate the view to see the lens elements
in a lens barrel. The model is shown below. 

FIGURE 21 - ACIS Tessar Lens File opened in TracePro
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Example - Gradient Index

TracePro can evaluate many types of optical materials including Gradient Index (Not available in
TracePro LC or TracePro RC). This example will demonstrate raytracing for gradient index and
illustrate the methods for importing property data and adding user data.

From the File menu select Open. Navigate to the Demos folder and open the Gradient Index
folder. Pick LuneburgLens.OML and press Open. Open the Source Pane in the System Tree and
notice that Grid Source 1 is green checked for inclusion in the ray trace. Press the Source Trace
button on the Analysis toolbar to trace the currently defined grid. Some errors will be displayed
indicating missing property data. 

Select the Tools|Database|Import menu or press the F11 key. The File Dialog should be
open to the Demos\Gradient Index folder and display the file Grin Props.txt. Select the file and
press Open. Trace rays again to see the effect of the Gradient Index as shown.

FIGURE 22 - Ray Trace of Gradient Index Luneberg Lens Model
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Next, you can modify the property by opening the Gradient Index editor using the Define|Edit
Property Data|Gradient Index Properties menu, select Luneburg Lens from the drop down
list, and press Edit|Unlock Property.

FIGURE 23 - Grin Property Editor Dialog 

Change the nr1 coefficient to 2. Select File|Save to update the database and trace a Grid
Raytrace as above. TracePro automatically updates the model to use the new data. The updated
raytrace is shown below. Notice the shift in the focal point.

FIGURE 24 - Updated Ray Trace of Gradient Index Luneberg Lens Model

Change the value of nr1 from 1 to 2Lock/Unlock Icon
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Example - Prisms

The Prism examples illustrate polychromatic properties of optical materials. This example will
demonstrate raytracing through two prisms shows the rainbow spectrum as the light is dispersed
by the prisms.

From the File menu select Open. Navigate to the Demos folder and open the Color folder. See
“Example Files” on page 6. Pick 2prisms.OML and press Open. Open the Source Pane in the
System Tree and notice that Grid Source 1 is green checked for inclusion in the ray trace. Press
the Source Trace button on the Analysis toolbar to trace the currently defined grid. 

The figure displayed below shows three TracePro windows, two Model Windows with their System
Trees and an Irradiance Plot in CIE model. The Model Windows are in Render Mode.

FIGURE 25 - Ray Trace and Irradiance Plot of Prism Model

To see a similar output, perform the following operations:

• After the raytrace, Select View|Render to change the mode of the Model Window.

• Select Window|New Window to open (or press the New WIndow button) a second Model Window.
Set the View mode to render. 

• You can change the viewing orientation by using the View|Rotate|Orbit menu or pressing the
Orbit Rotate View button.

• In the System Tree, select the surface named Observation Plane from the object named Screen.

• Select Analysis|Irradiance Maps (or press the Irradiance Maps button) to see this irradiance
map.

• Resize the windows or use Window|Tile commands to arrange the windows in a visible layout.
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Example - LCD Projector

This example shows the optics for a LCD projector. The light source is split into three channels,
red, green and blue. The three channel are recombined to form the output image. 

From the File menu select Open. Navigate to the Demos folder and open the LCD Projector
folder. See “Example Files” on page 6. Pick Projector.OML and press Open. 

Select the Tools|Database|Import menu or press the F11 key. The File Dialog should be
open to the Demos\LCD Projector folder and display the file LCD Projector properties.txt. Select
the file and press Open.

From the menu select Analysis|Source Raytrace and press the Trace Rays button. You can
also start this type of ray-trace by pressing the Source Trace button on the Analysis toolbar. 

The figure is shown in Render Mode with the rays leaving the source, split into three channels and
recombined as they exit the projector housing.

FIGURE 26 - Ray Trace of LCD Projector Model

Red Channel

Green Channel

Source

Blue Channel
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Models

The Examples\Demos folder contains model and property files. Follow the procedure described
in the Examples Chapter to open the model file (oml) and load property data (txt) using the F11
key.

File Description

ACIS\tessar.sat ACIS file of lenses in a barrel

Billboard\billboard.oml Illuminated billboard with base lamps

Color\2prisms.oml
Color\SF6Prism.oml

Prism examples with polychromatic raytraces

Elliptical Reflector\eliprefl.oml Metal halide lamp in elliptical reflector

Exit Sign\Multiple LED Exit Sign.oml
Exit Sign\Exit Properties.txt

Exit sign with lamps and additional property 
data

Eye Model\Eye_Model_CGBF.oml
Eye Model\Ant. Lens Cortex.txt
Eye Model\Aqueous Humor.txt
Eye Model\Cornea.txt
Eye Model\Lens Nucleus.txt
Eye Model\Post. Lens Cortex.txt
Eye Model\Vitreous Body.txt

Eye model with additional property data

Front Light\frontlight.oml Side illuminated light pipe

Gradient Index\LuneburgLens.oml
Gradient Index\Grin Props.txt

Gradient index ball lens with additional prop-
erty data

Integrating Sphere\intspher.oml Integrating sphere model

Laser Pumping\Pumping example.oml
Laser Pumping\pumping.txt

Diode pumped laser rod for Volume Flux dem-
onstrations with additional property data

LCD Projector\Projector.oml
LCD Projector\LCD Projector properties.txt

LCD projector model with additional property 
data

Lens Demo\DBLGAUSS.oml
Lens Demo\lensdemo.oml

Optical imaging and stray light models

Luminaire\louver.oml Fluorescent fixture with louvers
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Medical Tissue Tutorial\
      Medical tissue tutorial file with importance 
sampling.oml

Medical Tissue Tutorial\
      Medical tissue tutorial file.oml

Medical Tissue Tutorial\
      Medical Bulk Scatter.txt

Model for tissue tutorial with additional prop-
erty data

OSLO\DEMOTRIP.len
OSLO\PETZVAL.len

OSLO lens file for lens import

Polarization\BrewsterAngle.oml
Polarization\FresnelRhomb.oml
Polarization\PolarizingComponents.oml

Models showing polarization effects

Radio Lightpipe\radio lpiron.oml Lightpipe for dash illumination

RGB LEDs\3 LED RGB.oml
RGB LEDs\led 20 blue.txt
RGB LEDs\led 20 green.txt
RGB LEDs\led 20 red.txt

Three color LEDs combined to show  color 
components of white light

Street Light\street lighting.oml Street light illuminating a road

Tail Lamp\reverse taillamp.oml Automotive tail lamp model

Tunnel\Tunnel.oml
Tunnel\Holophane Flood.txt

Illuminated tunnel using Holophane flood 
lamps with additional property data

FluorescenceTutorial\Fluorometer.oml 2 channel fluorometer

LuminanceMapTutorial\glass sphere on 
checkerboard.oml

LuminanceMapTutorial\glass sphere on red-
white checkerboard.oml

LuminanceMapTutorial\paint, flat1.txt

LuminanceMapTutorial\GlassSphere-
OnCheckerboardProperties.txt

Glass sphere on checkerboard

File Description
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3DTexturesRepTilesTutorial\MicrolensAr-
ray.oml 

3DTexturesRepTilesTutorial\MicrolensArray3
DTextures.txt

Spherical microlens array (Brightness 
Enhanced Film) with RepTile property data

File Description
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